Slowdown on BentoBox services
Incident Report for BentoBox
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 14:33 EDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2022 - 14:33 EDT
Investigating
We are currently investigating a platform wide performance degradation issue.
Posted Apr 04, 2022 - 13:24 EDT
This incident affected: Websites and E-commerce, Online Ordering, or Pre-Order & Catering.