Some users are having trouble logging into BentoBox
Incident Report for BentoBox
Resolved
At 10:26 AM ET on 3/6, our engineering team identified an issue impacting some users’ ability to log into BentoBox. Our team worked quickly to resolve the issue, and we were back up and running at 11:19 AM ET. Thank you for your patience.
Posted Mar 06, 2024 - 11:33 EST
Investigating
BentoBox is currently experiencing an issue impacting users' ability to log into BentoBox.

Our engineering team is actively working to investigate the issue as quickly as possible. We're very sorry for the inconvenience and appreciate your patience as we work through this.
Posted Mar 06, 2024 - 11:04 EST
This incident affected: Websites.