Square Services Disruption
Incident Report for BentoBox
Resolved
As of 17:53 EST on February 6th, our Square partner has confirmed that their main service disruption was resolved. For more details on this incident, please visit their status page: https://www.issquareup.com/
Posted Feb 07, 2024 - 08:25 EST
Monitoring
Our Square partner is currently experiencing a disruption to their services, affecting some users during checkout. Not all Square customers are impacted, and some diners are able to check out after a few retries. Please refer to the Square Status Page as we continue to monitor, https://www.issquareup.com/

We're very sorry for the inconvenience and appreciate your patience.
Posted Feb 06, 2024 - 11:47 EST
This incident affected: E-commerce, Online Ordering, or Pre-Order & Catering.