Clover Services Disruption
Incident Report for BentoBox
Resolved
As of 22:32 EST on February 21st, 2024, our Clover partner has confirmed that their service disruption was resolved. For more details on this incident, please visit their status page: https://status.clover.com/incidents/30vzx8g94f39
Posted Feb 21, 2024 - 23:03 EST
Monitoring
Our Clover partner is currently experiencing a disruption to their services, affecting some users during checkout. Please refer to the Clover Status Page as we continue to monitor, https://status.clover.com/

We're very sorry for the inconvenience and appreciate your patience.
Posted Feb 21, 2024 - 18:31 EST
This incident affected: E-commerce, Online Ordering, or Pre-Order & Catering.