BentoBox e-commerce stores are experiencing high load times

Incident Report for BentoBox

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 20:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 20:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 19:50 EDT

Investigating

BentoBox is currently experiencing performance issues that are affecting e-commerce stores' ability to load.

Our engineering team is actively working to investigate the issue as quickly as possible. We're very sorry for the inconvenience and appreciate your patience as we work through this.
Posted Mar 19, 2025 - 19:48 EDT
This incident affected: E-commerce, Online Ordering, or Pre-Order & Catering.